Taranis X9D Plus will not boot up

Hardware help and support for the FrSky Taranis
Post Reply
Posts: 1
Joined: Sat Jun 25, 2022 11:23 am
Country: -

Taranis X9D Plus will not boot up

Post by MrNokia »

Hello Everyone,
My X9D Plus (not 2019) has given up on me.

I have already referred to the following posts to try and resolve the issue:
viewtopic.php?f=97&t=10031 and
viewtopic.php?f=97&t=13683&p=155592&hil ... er#p155592

My TX is a Taranis X9D Plus (not 2019). The battery I am using is a 3 cell LiFe which currently measures 9.8V
With the battery connected, the TX will not turn on. When I disconnect the battery and reconnect, the TX tries to turn on and briefly shows the OpenTX splash screen, squeaks (or starts to say Welcome and then the screen goes blank.

Before I started checking around the regulator (see results below), if I disconnected the battery, moved the power switch to the ON position and then reconnected the battery, the TX would boot up OK but if I turned the TX off, I had to disconnect the battery again to get it to turn on. However, after prodding around checking voltages I now get the same result where it tries to boot and then gives up whether turned on or off.

Board is marked X9D_MAIN PLUS REV0.3

With the battery disconnected:
R77 starts at 7.7k then rises exponentially to 9.6k
R76 starts at 9.9k then rises exponentially to 29.1k
L3 measures 0.4 ohm so is not open circuit
D4 has a forward voltage of 0.75V
C54 is an SMD electrolytic capacitor marked 9E 47 25J - a 47uF 25V - it is not short circuited
C64 consists of a board mounted SMD capacitor marked 226C - a 22uF 16V Tantalum with a 1000uF 6.3V electrolytic connected in parallel - the pair are not short circuited

With the battery connected I measured:
0.8v at the junction of R76 and R77 - the regulator voltage sense input
3.27V at the junction of L1 and C64 - the regulator output voltage
9.8V C54 and C55 - the regulator input voltage

Referring to the datasheet for the TPS5401 (Section 8.2 Typical Application), the resistor/capacitor network on the COMP pin (pin 8) of U3 looks odd - it looks as if R71 and C63 should be swapped - however, it worked before so this should not be a factor.

I feel the problem with my X9D Plus is in the vicinity of the regulator as it got worse when poking around to measure voltages and trace tracks.

With no battery connected, I get the STM Bootloader recognised by the PC and can read and write firmware to the TX - I get 4.85V at the input to the regulator, 3.26V at the output and 0.8V at the sense input

I'm at a loss where to go from here - any help is greatly appreciated.


Post Reply

Return to “FrSky Taranis radio”