I can't get my servos to move...

Post Reply
Posts: 3
Joined: Fri Nov 30, 2018 7:38 pm
Country: -

I can't get my servos to move...

Post by careyn » Fri Nov 30, 2018 7:47 pm

I just got a new Turnigy 9X from hobbyking. I've flashed it with the latest er9x, and that worked fine.I'm trying to configure my plane now and that isn't going so good.

The receiver is bound and is listening to the radio. If I turn off the tx, the rx starts blinking. Turn the tx back on, the blinking stops. So I figure they're talking. However, I just noticed that when I move a stick on the tx, the red led on the back of the tx goes out. I sort of think that means that it has stopped talking, but the rx is still solid led happy. Turning of the tx makes the rx blink.

Nothing I do in the mixer seems to make a difference. I've added, cleared, used a template, tried other channels with switches, but nothing will compel the servo to move. I even dug out the servo tester to make sure that it actually worked, which it did.

So I'm kind of stuck. I seem to have a bit of a brick on my hands. Is there something in the mixer I've missed like "actually pour this out of the antenna?" I've looked for something like that just in case there's another link in the chain, but I haven't seen it.

Any ideas? I'm sure it is some noob thing I've missed, but I'm not managing to find it.


User avatar
9x Developer
Posts: 17849
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: I can't get my servos to move...

Post by MikeB » Fri Nov 30, 2018 11:30 pm

What Tx module and what receiver are you using.
One thing to try is change the polarity of the PPM signal, swap between POS and NEG.

erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Post Reply

Return to “er9x model setup”